Nothing displaying when opening a project

I'm probably doing something wrong here but stumped.

Been working with 3.7.7 (windows, chrome) been fine up until a couple of days ago. but now I can't open or create projects. I've tried uninstalling and reinstalling, but same thing happens - either I try and create a new project (tried a few different routes), and OR stops at the "Done" screen and doesn't create the project, or I open a project and the screen is blank. See below:

I noticed something about a macros vm here, but I don't know what that means....

Only other thing of note is that when I redownloaded 3.7.7, that the files took ~45 minutes to extract, which doesn't seem right :confused:

What is this I never contact you

@SaraThomas I've seen this kind of blank display in situations where a large project is taking too long to load (but I'm not sure about those errors in the console - the messages from velocity don't look right).

Is this a particularly large project?

Hi @Alex. These are messages from the OpenRefine support forum which you seem to have subscribed to. If you didn't mean to, please let me know and I can remove you

Thank you - and no, they're not, everything I'm working with at the moment is relatively small, between 100-1500 rows as I'm learning. (there is one at 8k rows, but I've not done anything on that since November)

Have tried creation through an uploaded csv, google drive link, clipboard, and wikimedia commons category, all getting the same blank screen (if they create at all).

Hello, I have a feeling the Java version might be the problem, or perhaps your PC recently underwent some update or system change of some sort.

Try downloading an older version of OpenRefine... Preferably one with Java.

Also if you have Java installed in your system, try installing it or updating.

From the console.log @SaraThomas posted they are already using the 'with java' version.

Do you have any extensions installed? Look in the /webapp/extensions/ folder in the OpenRefine install - some will be installed by default:

  • database
  • jython
  • phonetic
  • wikibase
  • gdata
  • pc-axis
  • sample

But if there are any additional ones then try removing these

Also, if you know how to, it may be worth checking the developer console in the browser for errors (The Beginner’s Guide to Chrome Developer Tools looks like a reasonable beginners guide to using the Chrome development tools if you haven't done that before). I'd be looking for errors in the "Console" tab or long requests in the "Network" tab

Also if there is any other information in the OpenRefine console please post these as well

Hi there - yes, Java would make sense! But the version I’ve re-downloaded is indeed the windows with Java version. Chrome settings are set to allow Java. Checked for other versions causing a conflict before I re-downloaded. Wondering if there’s something there that I’ve missed, will poke about…

Thankyou, I’ll take a look!

@ostephens following up on this sub-thread: I also got emails from this topic, and when opening the site I noticed that I was subscribed to it at the most verbose level ("watching", i.e. get notifications/emails from every individual message), even though it was just created. This had never happened before.

Checking my account settings (Preferences > Tracking), I can see that the Support category is included in my watched categories:

...even though I don't recall adding it (and don't recall receiving emails from other threads in the Support category before).

So my suspicion is that a site admin recently added the category to everyone's "watching" set by mistake, resulting in such emails being sent out. I believe only the News and Announcements category should be there.

Our site admin, @Martin has recently made these changes appropriately to mimic what our old mailing list with Google Groups was doing... which we used for News and Support. This was not a mistake on our part, but to ensure that folks indeed get emails, which is what they should have gotten from the onset of our move to Discourse forums.

The good thing is that now many folks are getting the emails to keep them informed.

However, for those folks that don't want any Support emails, they will see at the bottom of the emails where they can unsubscribe as shown:

thanks all for your help so far, it's greatly appreciated.

Ok, tried looking at the extensions in /webapp/extensions, that's all as it should be.

Downloaded a new copy of java, and it's mostly working.. @Stain I tried java 8 first, seemed to get a partial fix, and now have java 11 (downloaded from the link here Installing OpenRefine | OpenRefine), and unstalled java 8 so that there weren't any conflicts, as per the documentation I've seen.

Can now create projects and open projects from CSV, etc... but anything to do with Wikimedia Commons, although it will preview, shows up like this:

uninstalled and reinstalled commons extension, made sure it was in the right place.... still the same issue. trying to shift from rows to records hangs on "Waiting".

the macros.vm is still showing as not being found in the console - i found a file called macros.vm in webapp/modules/core, but it's at 0KB (not sure if that's significant)

Understood. Apologies for assuming it was a mistake. Cheers!


That's also a 0kb file on my install so that seems like it's normal - but I've never seen that error before (there are other places where macros.vm files live - for example in extensions).

I'm afraid at this point I'm rather puzzled. I wonder if any other users @thadguidry @antonin_d @tfmorris can suggests next steps for trying to identify what's going on

1 Like

aaah, good to know, thanks :slight_smile:

haha me too! and thanks again for your help and suggestions, it's greatly appreciated :slight_smile:


Velocity is what we use to handle a few things, in particular, it handles initializing the loading of log modules for OpenRefine and that extensions can use.

I can replicate the missing macros.vm easily by renaming mine in the /webapp/modules/core/ folder. And OpenRefine will still startup and work with Records in its data grid.

What is curious is that your missing or it cannot find macros.vm which is quite evident that something with the files and folder structure is not being extracted well? or Windows permissions issue. But your Windows users download path is exactly the same place that other users run OpenRefine from without problems, including me.

Java being installed on your system is not applicable or needed if you are using the OpenRefine with Java. Which you are.

Are you able to click on Rows mode at the top of the data grid, instead of it going into Records mode?

1 Like

Given a problem like this I would look for errors in the browser's Javascript console (which you can obtain with a right click anywhere in the page, then click "Inspect", which opens the developer tools in a panel: then you can switch to the "Console" tab). You can look for any errors there (generally displayed in red).

Did you try running OpenRefine without the Commons extension?

1 Like

If I switch from rows to records I get the "Waiting" screen.... indefinitely.

Agree on the Java, it shouldn't make a difference - but it wasn't working at all before I installed java separately to the OR-w-java. Despite it working fine up until about last week.

Someone mentioned above that perhaps there's been a computer update of some form on my machine, and certainly the fact that it was working fine up until a few days ago would point to that. But I'm not sure what to look for.

oooh, progress, we have an error:


Non-commons projects are loading fine, this is a project loaded from a small Commons category.