Error on uploading files to Wikimedia commons

Hi all,

When attempting to upload 214 new files (1908 Openluchtmuseum Arnhem Jan Geerling.tar.gz - Google Drive)) to Wikimedia Commons using OpenRefine 3.8 snapshot version I am getting the error message:

' =11:42:31.868 [..ting.EditBatchProcessor] MediaWiki error while editing [badtags]: The tag "openrefine-3.8" is not allowed to be manually applied. (938ms)'

which seems to prevent new files from being added to Wikimedia Commons…

I hope you can help me out with this because I am really looking forward to uploading my first batch of pictures with OpenRefine :slight_smile:

Thanks!

Michelle

I’m guessing the issue is that that the snapshot version has bumped to openrefine-3.8 following the release of the 3.7 beta, and this tag is either not configured in the wikibase configuration at the OpenRefine end, or not added to Wikimedia commons. I can see someone reported a similar issue here Make Wikibase tag configurable in the manifest · Issue #3359 · OpenRefine/OpenRefine · GitHub

Perhaps @antonin_d or @Sandra who have more experience with using OpenRefine to upload to Wikimedia commons can help?

I can see that there is no openrefine-3.8 tag on this page https://commons.wikimedia.org/wiki/Special:Tags - I suspect it will need adding before you can use a snapshot build to upload.

Is there any reason to use the snapshot build rather than a released version?

Indeed this tag was not created on time - I had requested it a while ago on Wikidata but not on Commons. I think @Michelle is on it though, so that should be solved soon.

That being said, using different tags for each minor release feels a bit over the top. I am not aware of an instance where this granularity was useful - apart perhaps for monitoring the adoption of releases among the Wikimedia community.

Removing the versioning on those tags is quite easy:

That should prevent this problem from happening in future releases (and the same would be worth doing for Wikidata).

1 Like

Isn’t this also an extra layer of complexity for implementing Wikibase manifests?

For Wikimedia Commons, I think it totally makes sense to only have the OpenRefine tag (without version). I am currently super busy with our final report for the Wikimedia grant (will also post it here soon), but perhaps someone else would like to have a go at this process? @thadguidry perhaps? :wink:

Hi Owen, just answering your question in addition to the suggestions made in the thread above: the reason I am using the snapshot version is that - in my believe- the released version does not have the functionality to upload files to Wikimedia Commons build into it.

Thanks @Michelle. Is this functionality in the 3.7 beta release?

If was the creation of this release which bumped the tag of the snapshot build from 3.7 to 3.8 leading to the failure above. I don’t know exactly how this works so apologies if I’m off track, but the 3.7 beta release includes the functionality

New media files can be uploaded to Wikibase instances such as Wikimedia Commons. The wikitext of existing files can also be edited thanks to the new fields introduced.

So that might now work?

Hi @ostephens, thanks for getting back to me so quickly! I tried the 3.7 release but I had another issue (upload process to Commons stuck at 0%). But I might try it again and see if it would work now (or have a closer look at the reason why it was not working). I will keep you updated!