Joining Multi Value Cells Not Completing

I am attempting to join multi-value cells and the action is not being performed. OpenRefine includes the action in the Undo/Redo panel, but the cells are still separated. I have it set to "Show As: Records." I have tried on both Chrome and Firefox with the same result. I am using Version 3.7.6 with Java.

@MRoth are you able to share a screenshot or some example data? My guess is that OpenRefine isn't recognising the rows are part of the same record, but it's hard to know if this is right or why this is happening without an example.

One thing I found this morning is that blank rows are disappearing when the column is split.

Thanks! I can see that although you are in "records" mode, the rows in the display are all being treated individually - this can be seen because of the alternative shading (white/grey) on each row. If you scroll to the lefthand of the project, what are the values in the first column? This first column will be the one that determines how the rows are grouped together into records - and at the moment it looks like the grouping is one row equals one record, rather than the record grouping together several rows

Right now the first column is empty. My department is waiting for files to upload into a repository to get a URL for it.

The way that Records are calculated in OpenRefine is by looking for values in the first column. So with a blank first column OpenRefine isn't going to recognise the rows as part of a single record. So in this case it looks like you could achieve this by:

  1. Move the ES..Title column to the left so it is first in the project
  2. Switch to "Rows" display mode
  3. Use the Edit cells -> Blank down option in the ES..Title column
  4. Switch to "Records" display mode

You should then find that OpenRefine correctly groups together the rows into records - you are looking for display like:

Screenshot 2023-11-07 at 15.39.03

You can see that although there are 3 rows, only the first one is numbered in the All column indicating that (in this example) all three rows belong to a single record. Hopefully at this point your 'join multi-valued cells' operation on your other column should work as expected

Great! It works like a charm. I also tried with moving the column only (not blanking down) and it also worked. Thank you so much for your help!

1 Like