Problem with Wikimedia Commons schema - not showing media options

Hi Everyone,

I’m following the Youtube tutorial for batch uploading to Wikimedia Commons with OpenRefine.
But when i made a schema, i don’t get the “add media” options.

This is my result:

The options for “File path”, “File name” and “Wikitext” don’t show up.

I’ve noticed that my “filename”-tag is not green, but i did create a new item for each cell (it’s green in the “rows” tab).

I’m logged in with a bot account, have the wikimedia commons wikibase and i’m using version 3.6.2 (w. Chrome as a browser). I was also able to re-create this problem on another PC.

If anybody knows where i’m going wrong, do let me know!

Hi Wouter,

Welcome to the forum!
Uploading new files to Wikimedia Commons is only available in OpenRefine 3.7, so you’ll need to download version 3.7-beta2 for that. You can do so here (mind that the big download button will give you the latest stable version, which is 3.6):

Let us know if you encounter other problems with 3.7.


Hi Antonin,

Thank you for your reply.
I indeed had the wrong version. I’m on the 3.7 version now and it works as expected.

I did have trouble running the 3.7-beta2 (2022-12-12).
I’m on the latest Java version (, but clicking “openrefine.exe” takes me to the documentation page. The program seems to think that I don’t have Java installed.
This happens on both the version with and the one without Java.

I was able to download the older 3.7-beta1 version and don’t have any problems with this version.

Kind regards,

Yes something has apparently gone wrong with 3.7-beta2, and I am still not sure what. We’ll make sure this is solved before a stable release of 3.7.

1 Like