Running OR with the memory flag seems to ignore it


When launching OR with the memory parameter set the program log outputs this «Your current configuration is set to use 1400M of memory.» message. Is this the expected memory behavior?

@olea which operating system is this on with which OpenRefine build and version? (I run the Linux version on macOS which definitely has this problem, but I'm not aware of it being a more general issue)

Using Fedora Linux 38. This is happening from some OR versions to now. Also in Fedora 36 before updating to 38.

To be honest, I really don't know if this is a real problem or just an ambiguous message :slight_smile:

If you comment out the line


in the refine.ini file (by adding a # to the start of the line), and then restart OR - do you get the more expected outcome?

Pretty sure now that the problem is that refine.ini is processed after the command line arguments, so anything that is set in both places ends up using the refine.ini value. Tested locally and after commenting out the REFINE_MEMORY line in refine.ini it works correctly

1 Like

Should I open a bug issue?

That would be great! I can't do it right now although happy to help create the bug later if I can add anything.

(Also realised that the Mac issue I mentioned first is slightly different to this issue you're seeing - so don't worry about that aspect!)

@olea did my suggestion of commenting out REFINE_MEMORY line in refine.ini work? I've been doing some more tests locally and struggling to recreate the "fix" but want to check if it worked for you!

It did. Thank you :slight_smile: